Edit

Exporting & Importing

Transferring data electronically from MoneyWorks for use in other applications (such as spreadsheets or word processors) is called exporting. Bringing electronic data into MoneyWorks is called importing.

MoneyWorks has extensive exporting and importing capabilities to allow you to transfer data to and from other applications. Information can be transferred either through the clipboard (using the Copy and Paste commands), through files (using the Import and Export commands), or directly to other applications using AppleEvents on the Mac or COM on Windows.

Exporting

There are several ways of exporting information from MoneyWorks. Virtually any report or list that you print can be exported to either an html or text file by setting the output to an HTML or Text file. In addition, the individual records themselves (transactions, accounts and so forth) can be exported by use of the Export Selection command in the File menu (or by clicking the Export Toolbar button)—The resultant file will be a tab delimited text file which can be opened by most mainstream applications1.

You can also use the Copy command in the Edit menu to copy the highlighted records in the list. They can then be pasted into another application.

Exporting When Printing

Whenever you are printing, whether it is a report from the Reports menu or just one of the lists on the screen, the Print Settings dialog box will be displayed. Set the Output to pop-up to HTML File or Text File as shown below. You can also export directly to Excel, Word or the clipboard.

Clicking the Save As... button will display the standard File Creation dialog box, where you name the file and choose its type (tab delimited or html).


1  To open the file in the target application, you should start the application and choose Open from its File menu.