Removing TAX from tax Invoice form

For ideas, tips and tricks and comments on using or creating MoneyWorks Forms (invoices, statements, labels etc.),
Forum rules
This forum is not the official Cognito Software support channel for MoneyWorks. If you need help from Cognito, then please contact us (or your local regional support representative) directly using the contact information on the Support page of the web site.

Please try the search facility before posting a new topic to see if your topic has already been covered.

If you do post a new topic, it's a good idea to choose a Topic Subject that it a bit more informative than "Help!" or "A problem". If your topic is actually recognisable by people scanning the forum, you'll have a much better chance of getting a response. Thanks and have fun.
Post Reply
Posts: 2
Joined: 01 Oct 2013 13:18
Product: Express
Region: Australia

Removing TAX from tax Invoice form

Post by bensearle54 » 01 Oct 2013 13:21


I am a sole trader who does not need to charge GST until I reach a specific income limit. However, the Invoices I have generated put the words Tax Invoice and then the number of the invoice on the form. I can't see where the words Tax Invoice come from nor how to remove the word TAX from this. Any help would be greatly appreciated.

Posts: 8
Joined: 22 Dec 2010 00:10
Region: Australia
Location: Bondi

Re: Removing TAX from tax Invoice form

Post by publiclee » 24 Nov 2014 15:35

I have the same problem except and I can see where the source is.

In the template double click on the data box containing the problem. In my case it reveals the calculation that generates the combination of "TAX INVOICE: xxxxxxxxx":

Code: Select all

if(!CN, InvoiceTxt, if(left(locale, 1) = "A", "Adjustment Note", "Credit Note")) + " " + Transaction.OurRef

"InvoiceTxt" is a field that you can select from the calculation builder however how it works out whether it should say "TAX INVOICE" or "INVOICE" should be determined by whether you have elected to account for GST in the Document Preferences. Unfortunately it doesn't seem to respond to that selection.

The calculation for InvoiceTxt is wrong. Find the box on your form that calculates it. This is what it probably contains:

Code: Select all

if(PositionInText ("UCG", left(Locale, 1),  1) > 0, "Invoice", "Tax Invoice")

Replace it with this:

Code: Select all

if(GSTProcessingSuppressed > 0, "Invoice", "Tax Invoice")

BTW if your modifying your tax invoices here are the current guidelines for laying them out (yes, the ATO being helpful): ... nclude_GST

Post Reply